Sending Money from HKD - Bank transfers disabled
Incident Report for Wise
Resolved
This issue has now been resolved.
Posted Oct 13, 2021 - 13:03 BST
Identified
At the moment, only customers who’ve used us in the past can pay for HKD transfers using their debit or credit card. Our team is already on it, and working to bring back bank transfers as a payment method soon.
Posted Oct 13, 2021 - 09:59 BST