Delay with Euro payments

Incident Report for Wise

Resolved

This incident has now been resolved
Posted May 20, 2026 - 11:58 BST

Update

We are continuing to work on a fix for this issue.
Posted May 19, 2026 - 12:04 BST

Identified

Euro payments are currently taking longer than usual and we are monitoring the situation closely.
Posted May 19, 2026 - 11:59 BST
This incident affected: 📱 Mobile App, 📰 Website, 💱 Account, 💸 Payments, 🔗 API, and ✉️ Customer Support.