Issue with displaying transactions

Incident Report for Wise

Resolved

This incident has been resolved.
Posted Oct 24, 2025 - 16:07 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 24, 2025 - 14:48 BST

Investigating

We are currently experiencing an issue which can cause transaction details not to be displayed for some customers. Our teams are working to resolve it and will update the status accordingly.
Posted Oct 24, 2025 - 12:10 BST
This incident affected: 💱 Account and 💸 Payments.