Service disruption

Incident Report for Wise

Resolved

This incident has been resolved.
Posted Sep 01, 2026 - 13:43 BST

Investigating

We're aware of a technical issue affecting our platform. As a result, some customers will see receive an error message when setting up a payment or using their Wise card. Our team is already working on a fix.

This issue also impacts Wise Platform customers.
Posted Sep 01, 2026 - 13:26 BST
This incident affected: 💸 Payments, 💳 Debit Card, and 🔗 API.