Some customers experienced issues signing up for a new Wise account on our website and mobile app. The issue has now been resolved and sign-up is working as normal.
Posted Aug 24, 2026 - 11:47 BST
Investigating
We are aware of an issue and are currently investigating.
Posted Aug 24, 2026 - 11:26 BST
This incident affected: 📱 Mobile App, 📰 Website, and 💱 Account.