Transfers delayed

Incident Report for Wise

Resolved

This incident has been resolved.
Posted Nov 24, 2025 - 15:55 GMT

Monitoring

Between 1.01 and 1.24pm UTC we experienced a technical issue that slowed some transfers globally, including those sent via Wise Platform APIs. We’ve deployed a fix and systems are recovering, but transfers set up during the time of the incident may still complete more slowly than usual. Our teams are monitoring closely and we're sorry for the disruption
Posted Nov 24, 2025 - 13:57 GMT