Service Disruption

Incident Report for Wise

Resolved

This incident has been resolved.
Posted May 29, 2026 - 15:04 BST

Investigating

We are aware of an issue and are currently investigating.
Posted May 29, 2026 - 13:56 BST