Brazil: Wise Card to Apple Pay

Incident Report for Wise

Resolved

This incident has been resolved.
Posted May 08, 2026 - 18:28 BST

Update

We are continuing to investigate this issue.
Posted May 08, 2026 - 13:26 BST

Update

We are continuing to investigate this issue.
Posted May 08, 2026 - 13:25 BST

Investigating

We are currently investigating an issue affecting customers in Brazil attempting to add their Wise cards to Apple Pay via the Wise app. Our partners and our team are working to resolve the issue as swiftly as possible. In the meantime, customers can still add their card manually by entering the card details directly into the Apple Wallet app.
Posted May 08, 2026 - 13:25 BST
This incident affected: 📱 Mobile App and 💳 Debit Card.